8.5 Testbevindingen gebruikerstests
e-ABS 8.5 Testbevindingen tijdens gebruikerstests
Oplossingen voor bepaalde situaties / bekende fouten
ALGEMEEN
Melding 30595 - Situatie
Bij het openen van een document wordt een popup met een foutmelding getoond, waarin wordt gemeld "Fout: Document [...] is niet aanwezig en kan niet worden geopend."
Een dergelijke melding is terecht wanneer een document geopend wordt dat op het moment dat de GAT database werd gekopieerd (16 juli 2026) ouder was dan 130 dagen.
Documenten die niet ouder zijn dan 130 voor 16 juli horen gewoon te openen en een lege pdf te tonen. Maar ook bij die documenten komt nu deze melding.
Status: De oorzaak is achterhaald. Het is voor nu even niet anders. Bij de volgende verversing van de data zal dit weer gaan zoals bedoeld.
Alleen documenten die zijn toegevoegd ná 16 juli kunnen wel gewoon geopend worden.
Melding 30574 - Situatie
Een verschil in de namespace zorgt voor blokkerend probleem bij ANVA. De response berichten vanuit e-ABS kunnen daardoor niet verwerkt worden.
Status: De aanpassing om deze fout op te lossen is 28/8 op GAT/WIT opgeleverd.
Melding 30574/30654 - Situatie
Een verschil in de namen van velden in de webservice berichten die vanuit ANVA naar e-ABS worden gestuurd zorgen voor foutmeldingen bij een aantal webservices. Het gaat (voorzover wij weten) om de volgende webservice:
- PolicyHolder webservice
- Claim webservice
- Settlement webservice
- Pool webservice
Status: ANVA zorgt ervoor dat deze fouten worden opgelost en zal voor hun klanten een patch uitgeven, waarmee dit probleem moet zijn opgelost.
Hoofdmelding 30640 - Situatie
In verschillende situaties wordt bij het aanleveren vanuit Level het geselecteerde/aangemaakte document niet meegestuurd naar e-ABS. Het gaat (voorzover wij weten) om de volgende webservice:
- AdditionalDocument webservice
- PolicyVersion webservice
- Claim webservice
- Settlement webservice
Status: CCS zorgt ervoor dat deze fouten worden opgelost en zal voor hun klanten een patch uitgeven, waarmee deze problement moeten zijn opgelost.
Hoofmelding 30779 - Situatie
Bij het uploaden van een groot bestand in e-ABS komt de foutmelding
Foutmelding: [1} Internal error
rest.gateway.call.failed
Status: De oorzaak van deze fout is gevonden. Er blijkt sinds 8.5 in de GUI een (onbedoelde) beperking op het aantal MB van een document te zitten van 20mb.
We gaan dit met patch 8.5.2 oplossen. Naar verwachting wordt die 30 september op productie opgeleverd..
In de tussentijd is het advies om kleinere documenten te uploaden en als het om downloaden gaat van een groot document dat al in e-ABS staat, dan het document opvragen via mail bij de organisatie die het document heeft geupload (via webservices geldt deze beperking nl. niet).
POLISSEN
Melding 30586 - Situatie
Bij het accorderen van een polisversie waarbij een zgn. 'ondertekening' wordt gebruikt verschijnt de foutmelding "Fout: Kon het bestand /mnt/documentenrepository/gat/..../../../... niet lezen", waardoor het accorderen niet kan worden uitgevoerd.
De oorzaak is bekend: ook dit komt doordat niet alle documenten in de GAT database aanwezig zijn.
Bij de ondertekening kan een ondertekenspecificatie worden ingeregeld. Deze ondertekenspecificatie is ook een bestand en dat bestand ontbreekt dus.
Workaround
- verwijder de ondertekenspecificatie, nu kan er wel geaccordeerd worden
OF - verwijder de ondertekenspecificatie en voeg een nieuwe ondertekenspecificatie toe. Dat bestand is dan wel aanwezig, zodat het gevonden wordt bij het accorderen
OF - kies bij het accorderen in de kolom 'ondertekening' in de dropdown voor 'werkmaatschappij standaard ondertekening'. Hier is de ondertekenspecificatie niet nodig en kan de accorderen worden uitgevoerd.
SCHADE
Situatie
Wanneer er met de webservice createClaim van endpoint ClaimsWebservice_7.9 een document wordt toegevoegd, komt de fout terug common_exceptions.field_not_null,documentIds.
Status: Deze fout is inmiddels opgelost.
Situatie
Bij gebruik van de webservice updateClaim van endpoint ClaimsWebservice_7.9, komt de fout terug common_exceptions.field_not_null,claimInputVO.getClaimId().
Status: Deze fout is inmiddels opgelost.
Melding 30598 - Situatie
Willis heeft gemeld dat bij het aanmaken van een schade via ClaimWebservice_7.9 er wel een schadedossier wordt aangemaakt, maar dat niet de meegegeven groep/gebruiker als eigenaar aan het dossier wordt toegevoegd.
Status: Deze fout is inmiddels opgelost.
...